Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2025 - 04:00 CEST
Scheduled
Please be aware that on 01/Oct/2025, between 02:00 - 03:00 UTC, ESET Secure Authentication will undergo a scheduled maintenance. Customers will not be able to use ESET Secure Authentication. Thank you for your patience and understanding.
Posted Sep 29, 2025 - 15:13 CEST
This scheduled maintenance affected: ESET Secure Authentication (Europe, Africa, Asia Pacific, Americas, Oceania, Canada).