Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 09:30 CEST
Scheduled
Please be aware that on Tuesday, April 15 2025, between 7:30 - 8:30 UTC, ESET Business Account will undergo a scheduled maintenance. Customers will not be impacted by this release. Thank you for your patience and understanding.
Posted Apr 10, 2025 - 13:15 CEST
This scheduled maintenance affected: ESET Business Account.