Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2024 - 10:00 CEST
Scheduled
Please be aware that on September 25, 2024, between 08:00 - 09:00 UTC, ESET PROTECT Hub will undergo a scheduled maintenance. Customers will not be able to login and perform standard license actions. The aggregated downtime time should add up to around 10 minutes within the maintenance window. Thank you for your patience and understanding.
Posted Sep 20, 2024 - 16:47 CEST
This scheduled maintenance affected: ESET PROTECT Hub.