Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2024 - 10:00 CEST
Scheduled
Please be aware that on Tuesday, October 1, 2024, between 08:00 - 09:00 UTC, ESET PROTECT Hub will undergo a scheduled maintenance. Customers will not be able to login and perform standard license operations. The aggregated downtime time should add up to around 5 minutes within the maintenance window. Thank you for your patience and understanding.
Posted Sep 26, 2024 - 15:34 CEST
This scheduled maintenance affected: ESET PROTECT Hub.