ESET logo

Customers connected via Telia ISP cannot connect to ESET Cloud Services

Incident Report for ESET

Update

We are aware of an issue with the Telia internet service provider that prevents customers from accessing ESET Cloud Services. We will provide updates in due course.
Posted Jun 29, 2026 - 13:44 CEST

Investigating

We are aware of an issue with the Telia internet service provider that prevents customers from accessing ESET Cloud Services. We will provide updates in due course.
Posted Jun 29, 2026 - 13:40 CEST
This incident affects: ESET PROTECT (Europe, Africa, Asia Pacific), ESET Inspect (Europe, Africa, Asia Pacific), and ESET PROTECT Hub, ESET Business Account.