Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2024 - 09:00 CEST
Scheduled
Please be aware that on September 16, 2024, between 07:00 - 08:00 UTC, ESET MSP Administrator 2 will undergo a scheduled maintenance. Customers will not be able to login. The aggregated downtime time should add up to around 5 minutes within the maintenance window. Thank you for your patience and understanding.
Posted Sep 11, 2024 - 17:54 CEST
This scheduled maintenance affected: ESET MSP Administrator.