Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 09:30 CEST
Scheduled
Please be aware that on Wednesday, June 18 2025, between 07:30 - 09:30 UTC, ESET PROTECT Hub will undergo a scheduled maintenance. The release will be deployed seamlessly within the maintenance window, with no downtime or impact to customers.
Thank you for your patience and understanding.
Posted Jun 16, 2025 - 14:55 CEST
This scheduled maintenance affected: ESET PROTECT Hub.